Celocli error in ubuntu 20 LTS

Hi guys, I installed celocli on ubuntu 20 LTS to test arbitrage with hummingbot. I see my CELO and CUSD in my celo wallet inside hummingbot. Now I would like to transfer cusd to Valora app, so I used celocli command, but I get this error:

~/celo$ celocli transfer:dollar [my-celo-address]
Error: Could not locate the bindings file. Tried:
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/build/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/build/Debug/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/build/Release/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/out/Debug/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/Debug/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/out/Release/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/Release/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/build/default/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/compiled/10.19.0/linux/x64/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/addon-build/release/install-root/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/addon-build/debug/install-root/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/addon-build/default/install-root/usb_bindings.node
β†’ /usr/local/lib/node_modules/@celo/celocli/node_modules/usb/lib/binding/node-v64-linux-x64/usb_bindings.node

I get the same error for all celocli commands.

I hope tha someone could help me.
Thanks you!

Hi!

I have usually seen this happen when there is a problem with the global install of the cli (npm install -g @celo/celocli ). I would suggest you try to create a local install of the package (explained below), and then use the CLI with npx celocli at the folder’s root.

mkdir temp && cd temp
npm install @celo/celocli

Otherwise there is some useful information in this github comment as well.

Let me know if either of those solutions work!

By the way, for future questions, I recommend you join our Discord. Our entire community, from core developers to users and builders, resides there and would be happy to answer any of your questions! We often have a faster response time on that platform.

1 Like

Thanks for the answer, but neither solution works for me. Ok I’ll try to ask on Discord.