Problem installing celocli on aws ubuntu

I am having trouble installing celocli in ubuntu on aws. Does the team have the latest set of laymen friendly walk-through and dependencies? I followed all the steps in the celo docs Validator Setup FAQ doc using npm install, but I think I ran into something permissioning issues related to npm that I couldn’t fix. Logs and error messages below. Let me know if you have any ideas…

I can’t post the full log here because of a new user can’t post more than 2 links error. If someone is here to help, please message me.


System: Ubuntu 18.04.5 LTS (GNU/Linux 5.4.0-1025-aws x86_64)

ubuntu@ip-XXX-XX-XX-0 : ~ $ sudo npm install -g @celo/celocli --unsafe-perm

Hi @Howard, can you try adding the links / logs now? You should have permissions.

You can also join the Celo Discord server ( and ask this question in the #developerchat channel – folks may be able to help you out there sooner.

Thanks. I got the help I need from the discord group. Think it works now.

1 Like