[Multisig] Celo Safe (re)launch

Latest fix was deployed, normally transactions should not be pending anymore! :slight_smile:

2 Likes

This is great news, thanks for sharing! :pray:

We are in talks with the Safe team on Discord (Richard and co) for all things technical.
Would it make sense to include you there or how does SafeDAO deal with such proposals?

1 Like

Topic: API url base like Eth mainnet

Gnosis has this URL for the mainnet Safe:
https://safe-transaction-mainnet.safe.global/
(! Note the different API endpoints compared to the Alfajores one below)

For Alfajores, I could only find this (by inspecting the network on the reforked Safe’s UI
https://client-gateway.celo-safe-prod.celo-networks-dev.org/index.html
(api base: https://client-gateway.celo-safe-prod.celo-networks-dev.org)

Q: Could you point me to the “correct” Alfajores API?
For Celo would also be nice.
More specifically, we need access to sth like

  • POST /v1/safes/{address}/multisig-transactions/
  • POST /v1/safes/{address}/multisig-transactions/estimations/

EDIT: After continuing playing around with the reforked Safe UI, I found this undocumented endpoint
POST /v2/chains/44787/safes/{safeId}/multisig-transactions/estimations

Topic: Long indexing times?

I had 2 tx

  • one took ~10min to index
  • the other is still indexing at ~20+ min now

Any explanation you could provide?

:sparkles: Launch update :sparkles:

The new Celo Safe version is live at safe.celo.org :partying_face: :tada:

What you need to know:

  • Both Alfajores (testnet) and Mainnet are supported
  • All existing Safes will continue to work as before
  • If you prefer, you can continue using the previous Celo Safe version at old-safe.celo.org
  • If you can’t see your existing Safes, you can simply add them using “Add Safe” in the sidebar (see video below)

As before, Celo Safe continues to be a beta release :warning:
Please share bugs and feedback by commenting on this forum post below👇

All comments and reflections welcome! :pray:

1 Like

I tried to execute a transaction from my safe (0x73d2231a223e46864d9B35FEC712160c3A3AaBd6) on Celo Mainnet. It is stuck at indexing on https://safe.celo.org after the new update right now.
The safe transaction hash is 0x1d1eda2aa70be002061a41f60c21765cfbaebf8415b9ed68b0aadb5a3cadb11b

I have added a screenshot here - Screenshot 2022-11-16 at 6.20.38 PM.png - Google Drive

1 Like

Hi @richikchanda1999 and @owl_dev thanks both for reporting the indexing issue. Great catch!

Indeed, it looks like indexing is taking quite a while :thinking:
This is not behaviour we observed in testing but we’re able to reproduce it on our end, so @nicolasbrugneaux and @martinvol are looking into this right now!

Ref:

Edit: You can see the progress linked in this Github Issue

@0xarthurxyz

Congrats on the official (re-)launch!

I just wanted to bump my request about the “public” API base, as described in this post

Thank you!

1 Like

Bug Report: Conflicting txs beside already executed

Steps

  1. Reject tx in Queue (Nonce 6 !)

Issue
2.1 Conflict is showing up in Queue [1]
2.2 Despite tx already in History [2]
3. Now I cannot submit any other Txs, because I need to confirm Nonce 6 first
(4. Follow-up issue: When trying to confirm the “deploySeed” proposal, I get this error [3])

Expected
2. Tx is getting rejected and lands in History

[1] Safe – Transaction queue
[2] Safe – Transaction history
[3]

Your transaction was unsuccessful. cannot estimate gas; transaction may fail or may require manual gas limit (reason=“execution reverted: GS013”, method=“estimateGas”, transaction={“from”:“0xB86fa0cfEEA21558DF988AD0ae22F92a8EF69AC1”,“to”:"0xF1734d53F5560C319395D633D1

Report: Tx not showing estimate

STEPS

  1. Try to confirm a tx
  2. tx modal to confirm pops up
  3. “Estimating…” text on bottom right button

Result
4. not getting an estimate with error in the modal [1]
(5. follow-up issue: when I still “Confirm” the tx
6. Then error message pops up in the upper right corner [2])

Expected
4. Get an estimate


[1]
Happened for 3 days already
(can’t post screenshots :frowning: )

This transaction will most likely fail. To save gas costs, avoid creating the transaction.call revert exception [ See: Error Codes ] (method=“getGasPriceMinimum(address)”, data=“0x”, errorArgs=null, errorName=null, errorSignature=null, reason=null, code=CALL_EXCEPTION, version=abi/5.7.0)

[2]

Your transaction was unsuccessful. cannot estimate gas; transaction may fail or may require manual gas limit [ See: Error Codes ] (reason=“execution reverted: GS013”, method=“estimateGas”, transaction={“from”:“0xB86fa0cfEEA21558DF988AD0ae22F92a8EF69AC1”,“to”:"0xF1734d53F5560C319395D633D1

1 Like

Hey @owl_dev, thanks for asking! That’s a good question, I don’t know the Celo Safe base URL :thinking:

I logged your question in our Github backlog so we don’t forget about this and can prioritise getting you an answer vs other Celo Safe work items.

Ref:

1 Like

Hey @owl_dev, thanks for posting this bug report!

I logged your question in our Github backlog so we keep track of it going forward:

Could you paste the screenshots you struggled to paste here in a comment in the Github issue so we have as much context as possible when we look into this?

Thanks!

Ref:

1 Like

Hi all!

I’m Orkhan from Remox. We offer simplified and collaborative treasury management for DAOs and live on Celo (public beta). You can use multiple Celo Safe in one interface, onboard your contributor, run payroll, and much more. Looking forward to your feedback and ready to integrate the new Celo SAFE.

1 Like

Hi @owl_dev and thanks for the question and interest in the celo-safe, you deducted most of the information by yourself already in the network panel! :slight_smile: In order to help you a bit more, you can find the API documentation right here: Swagger UI :slight_smile: (the BASE_URL being https://client-gateway.celo-safe-prod.celo-networks-dev.org for both alfajores and mainnet) To distinguish between mainnet and alfajores, you must specify the chain_id (eg: 42220) in the requests URL itself

As a Delegate, I’m not 100% in the loop yet, as some initiatives are still with the Core team. There is no framework yet for expansion, but we can start conversing with them. Let’s maybe touch base somewhere soon for me to understand where you are already and if and how I can be helpful. I supported Balancer in creating the Balancer Friendly Fork framework; maybe we can do something similar for SafeDAO.

1 Like

Hey there, ty for the answer.

What I’m missing with your link are requests like

More specifically, we need access to sth like

  • POST /v1/safes/{address}/multisig-transactions/
  • POST /v1/safes/{address}/multisig-transactions/estimations/

In my original post [Multisig] Celo Safe (re)launch - #23 by owl_dev, I linked the Mainnet Gnosis Safe Swagger UI link, and they do have those endpoints.

Hi, congrats on the upgrade.
Any specific reason why the “Contract Interaction” option is not available in this new version?
Now the only options available to me are “Send Tokens” and “Send NFTs”

PS: I tried attaching a screenshot but it won’t let me.

Asked you a follow up on Github: Bug: Transaction error relating to not showing gas estimate · Issue #4 · celo-org/web-core · GitHub